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• PCB Artist is a free PCB schematic & layout tool provided by Advanced 
Circuits

• It can be downloaded from www.4pcb.com or www.download.com
• Pros:

– Free
– Intuitive and simple to use/install
– Autorouter
– Large libraries

Important Terminology
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– Large libraries
– East to create new parts (schematic symbols & footprints)
– No minimum quantity for students (see website)

• Cons:
– No interactive DRC
– Boards are ~$33/ea (2-layer, 5 day turn) or $66/ea (4-layer, 5 day turn)
– You do not get the gerber files (i.e. you must fabricate designs with 

Advanced Circuits)



• “mil”
– A “mil” is 1/1000th of an inch.  
– 1mil=.001”

• Layer
– PCBs are made of ‘layers’
– Here are the common layers

• Metal
– The actual 

wires/conductors

Important Terminology
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wires/conductors
• Silkscreen

– The white writing on the 
PCB

• Soldermask
– The green stuff

[2]
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• Trace
– The width of a metal wire

• Space
– The minimum distance between traces

• “Trace/Space”
– “6 mil trace/space” means the traces must be at least 6 mils wide 

and there must be at least 6 mils of space between traces

Important Terminology
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• Pad
– Surface mount (SM) and/or with hole

Important Terminology
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• Via
– A ‘via’ is a metal-plated hole drilled in the PCB that connects metal 

layers
– Four common types are ‘stub’, ‘through-hole’, ‘blind’, and ‘buried’
– Figures are from [3]

Important Terminology
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Advanced Circuits (AC) Specials

• These selections will depend on your design needs.
• If interested in the $33 or $66 specials, be sure to adjust settings 

appropriately
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AC Capabilities
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AC Tolerances
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• File->New
• Select New Project and 

specify path for *.prj file

New Project
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Add Schematic

• File->New
• Select New Schematic, assign 

file name and check Add to 
Open Project
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Add PCB Layout

• File->New
• Select New PCB Design, assign 

file name and check Add to 
Open Project

• Selecting OK will launch the 
PCB Wizard
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PCB Wizard

• Set units to “mils” and precision to “0”
– Precision is the number of places to the right of the decimal
– A value of “1” allows for measurements such as 15.8mils, but not 

15.75mils.  For 15.75mils, precision should be set to “2”
– Use ‘basic-minimums’ for board template
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PCB Wizard

• Select appropriate board service (most will probably be 2 or 4 layer standard)
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PCB Wizard

• For a 2-layer board the 
parameters will be 
straightforward
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PCB Wizard

• For a 4-layer board you 
can specify powerplane 
layers
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PCB Wizard
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PCB Wizard

• Select whether or not 
you want electrical 
testing (probably not)
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PCB Wizard

• Specify board part 
number, revision, and 
quantity

• Adjust turnaround time 
as needed
– 3 days is 

recommended
• Select Next, then 
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• Select Next, then 
Finish.



PCB Settings

• Grid
• Units
• Styles
• Spacings
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• Spacings
• Nets
• Net Classes



PCB Settings-Grid

• Settings->Grids
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PCB Settings-Units

• Settings->Units
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PCB Settings-Styles

• Settings->Styles
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PCB Settings-Spacings

• Settings->Spacings
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PCB Settings-Rules
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PCB Settings-Nets & Net Classes
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Example Design

• Let’s create the schematic and PCB for the 
following filter
– Active low-pass
– Fc=1kHz
– 4th order
– 2-stage
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– 2-stage
– Sallen-Key

• We can use TI’s FilterPro to obtain a generic 
schematic

• Then use TI’s TINA-TI to verify in simulation



FilterPro Design
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Amplifier Selection

• Let’s implement this filter with the OPA141
– Single-supply, 10MHz, RRO, Low-noise, JFET input 

(Ib=20pA max)
– Supply: 4.5V to 36V
– Packages

• Single (SO-8, MSOP-8)
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• Single (SO-8, MSOP-8)
• Dual (SO-8, MSOP-8)
• Quad (TSSOP-14, SO-14)

– Vicm includes GND



TINA-TI Simulation
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New Schematic Symbol Library

• Let’s create a new Library for custom schematic symbols
– Open Library Manager (Ctrl-L)
– Select New Lib
– Give new library a name
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New Schematic Symbol
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New Schematic Symbol

• For this device we will use the dual 
version (our filter has 2 amplifiers)

• From a schematic perspective, we will 
need 2 sub-symbols

– One will look like an ideal op-amp
– The second one will have power and ground
– Here is the idea using symbols from TINA

IOP1 OP1 !OPAMP
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• Note:  Please don’t use the package 
pinout as the schematic symbol!  This 
makes it difficult to read the 
schematic.
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New Schematic Symbol

• Create 2 separate symbols in the library
– Use “Add Pad” for the pins
– Use “Single Line” and “Triangle” for the symbol
– Move the symbol origin (S) to one of the pins
– The numbers correspond to the pins, “NX” is the pin name

• Save the symbols as myopamp3 and myopamp5
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New Schematic Symbol
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New PCB Symbol Library

• Let’s create a new Library for custom PCB symbols
– Open Library Manager (Ctrl-L)
– Select PCB Symbol tab
– Give new library a name
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OPA2141 Packages

• We need to determine which package we will use
• The datasheet typically has all the information 

required
• We see the OPA2141 comes in two packages

– MSOP-8
– SO-8

• TI refers to these packages as “DGK” and “D”
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OPA2141 Landing Patterns

• Let’s compare the D and DGK packages
• D is found in the PDS, but DGK is not!
• Here is a link to a useful app note
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New PCB Symbol

• Let’s use the DGK (MSOP-8) for it is smaller
• Create a new Library for custom PCB symbols

– Open Library Manager (Ctrl-L)
– Select PCB Symbol tab
– Give new library a name
– Let’s use the Wizard
– Use mils, precision 1
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New PCB Symbol
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New PCB Symbol

PCB Artist->App Note
*Set H=T=0
e=E=25.6
E=Z=230
L=Y=66
b=X=18
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New PCB Symbol
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New Component

• Now we have the schematic and PCB 
symbols, we can combine them to 
create a component

• Create a new component library (make 
sure component tab is selected)

• Click New Item
• Only select one of the schematic 

symbols, we will add the other one later

FEARLESS engineering

symbols, we will add the other one later



New Component

• Click Add Gate icon
• Add 5-pin schematic symbol
• ‘a’ will zoom to all in schematic and 

PCB windows

• You may have to right-
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• You may have to right-
click in top window to 
see spreadsheet



New Component

• Fill out spreadsheet according to datasheet block diagram & save component
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Create Schematic

• Create Schematic in project
• Use Add Component to instantiate 

OPA2141
• Note you can place each symbol 

separately
• Add Component->Find is very useful

– R’s are in library ‘resistor’
– C’s are in library ‘capacitor’
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– C’s are in library ‘capacitor’



Create Schematic

• Common passive sizes are 0402, 0603, 0805, and 1206
• Probably want size 0805 at least for hand soldering
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Note: 0.1mm~=4mils



Create Schematic

• Use ‘schema’ library for border (e.g. Letter) and power/ground
• Use ‘resistor’ and ‘capacitor’ libraries for R’s and C’s
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Create Schematic

• Use ‘connector’ library to add connectors or make your own
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Create Schematic

• Are we missing anything?
• Check datasheets for layout recommendations
• From the OPA141 PDS:
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• So we need to add decoupling capacitors near the device’s supply



Create Schematic
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These are bad!  Must use wire to connect!



Create Schematic
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Create Schematic

• Finally, we need to ensure that our power and ground nets are set 
appropriately

– Right-click a ground symbol
– Select “Change Net”
– Make sure net name and net class are set appropriately
– Also do this for +5V and -5V
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Create PCB

• Save and close schematic
• Open Layout
• Import footprints from Schematic

– Tools->[Schematic<->PCB]->Consistency 
Check

• I recommend performing Consistency Checks 
frequently during a design

– Yes
– OK
– ‘a’ to zoom all
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– ‘a’ to zoom all
– Select all footprints and move them outside 

PCB border
– ‘a’ to zoom all



Create PCB

• Yellow lines are connections that need to be made 
– Sometimes called ‘rubber bands’

• Place components inside green PCB border
– PCB Artist has an ‘autoplace components’ feature, but it doesn’t seem to work well
– Place the OPA2141, power connector, input connector, output connector, and decoupling caps
– In general, place inputs on left side of board, outputs on right, and power at top or bottom
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Create PCB

Notice lack of bands for supplies?  This is because they 
weren’t connected in schematic! (Remember the ‘X’s?)
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Create PCB

Supply nets and grounds are now connected.  Also fit board 
outline.  *Run DRC often!*  Tools->DRC (check Spacing and 
Manufacturing)
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Create PCB

• Since we have 2 layers, let’s make the bottom layer GND
• Need to perform a ‘pour’

– Add->Copper Pour->Rectangle
– Press “L” to change layer to ‘bottom’
– Create rectangle inside board outline
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Create PCB

• Right click copper pour outline and select ‘Pour Copper’
• Assign to GND net and click OK
• To hide bottom layer, press F9, select Layers tab, and uncheck 

‘Bottom Copper’
• Now we can use vias to connect to GND 
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Create PCB

• We know C3, C4, and C5 are all grounded
• We can place a via to connect them to the ground plane

– Add->Via
– ‘Esc’ stops placement

• Once placed, right-click via and add to GND net (Net->Change Net)
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Create PCB

• To route a trace to the via, double-click the pad of the footprint (notice the 
trace is 25mils wide)

• Drag trace to via and double-click again
• Do this for all GND nets
• Bands didn’t disappear, press ‘ctrl-d’ to ‘optimize nets’ (in tools menu)
• You can left-click band and press delete
• If bands are missing, try performing a ‘consistency check’ from tools menu
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Create PCB

• You may get a join nets box
• The order depends on where you start and end your trace
• To switch the order, route in the reverse order
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Create PCB

• I would hand-route power and GND first.  
• Since power traces are wider than MSOP-8 pads, route as close to pad as 

possible with thick trace.  Then route from pad to thick trace.  While routing from 
pad to thick trace, press S and change width to 18

• Run DRC often!  Don’t forget Ctrl-D and Consistency Checks!
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Create PCB

• You can try autorouting (3 methods)
– Right click a band and select ‘autoroute’ to route 1 trace at a time
– Tools->Autoroute Nets->All Nets to route all nets (it will remove your existing routes)
– Tools->Autoroute Nets->Browse Nets (we will do this since we already routed power and GND)
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• This didn’t work well for me, and I prefer to do it by hand anyways



Create PCB

• Almost done
• Are we stuck??
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Create PCB

• Nope!
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Create PCB -Reflection

• Some of the traces were long
• We could have looked at using a 4-layer board
• We also didn’t have to devote an entire routing plane to 

ground
• We could also have separated V+, V-, and GND connectors 

and moved them to more convenient locations.
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and moved them to more convenient locations.



Fabricate PCB

• Be sure to run a DRC with all boxes checked
• Output->Submit Order
• Follow the directions

– You will need to setup an AC account

• Alternately, I could submit the order for you.
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• Alternately, I could submit the order for you.
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All Materials have a Finite Resistance

For PCB Trace

For 1 oz. Copper:

ρ = 1.724 x 10-6 ∧-cm  for Y = 0.0038cm

R = 0.45 Z/X m∧ = number  of “squares”

R = sheet resistance for 1 “square”
( Z = X ) = 0.45m∧/square

R = ρZ/XY

X

Y

Z
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For Wire

L

d

R =

L in meters
d in mm

0.0219L

d2



PCB Trace Resistance

1 inch
1.3µV

10µA
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• 1 inch (7 mil) trace of 1/2 oz copper with 
10µA of current => voltage drop of 1.3µV 

• 4 LSBs (298nV) at 24 bits!



PCB Inductance

PCB:

L

W

H

(    )Inductance = 0.0002L  ln                + 0.2235               + 0.5    H

Example:
L = 10cm
W = 0.25mm
H = 0.038mm

This PC track has 141nH of inductance

2L

W+H
(    )W+H

L

FEARLESS engineering

Wire:

L

2R

Inductance = 0.0002L   ln             - 0.75    H

Example:
L = 10cm
2R = 0.5mm

This wire has 105nH of inductance

2L

R(   )



PCB Capacitance

• Two Cu plates with PCB material dielectric
– Two 10 mil traces on a multi layer PCB, 10 mil between layers

A = 0.25 mm x 0.25 mm

Permittivity of FR4 ≈ 4.7
∑o = 8.84 x 10 -12

FEARLESS engineering

Note: 10 mil = 0.25 mm.



Component: Vias 

Purpose: Interconnect traces on different layers

Problem: Inductance and Capacitance

PCB Vias
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0.4mm (0.0157”) via with 1.6mm (0.063”) thick PCB has  ≈ 1.2nH

1.6mm (0.063”) Clearance hole around 0.8mm (0.031”) p ad on FR-4 has ≈ 0.4pF

er = PCB material permeability (FR-4 ≈ 4.5) 
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Bypass Capacitors

• Used in all analog applications
• Used for bypassing (cleaning up) power 

supplies
• Most op amp applications use two types 

for the two roles they must fill
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for the two roles they must fill



Poor Bypassing

Bypass Capacitors

• DO NOT have vias between 
bypass caps and active device –
Visualize the high frequency 
current flow !!!

• Ensure Bypass caps are on 
same layer as active component 
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Good Bypassing

same layer as active component 
for best results.

• Route vias into the bypass caps 
and then into the active 
component. 

• The more vias the better.
• The wider the traces the better.
• The closer the better 



Balanced analog and digital circuit
(common-mode signals not welcome!)

FEARLESS engineering



Circuit techniques to minimize EMI

• Strive for a zero 
impedance ground

• Design for a 
differential signal 
environment, both 
logic and analog

• Minimize PCB loops 
that act as EMI 
antennas
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• Use X2Y capacitors 
for filtering and 
decoupling

• Make use of 
common-mode 
transformers

• Use balanced lines 
and traces



Enemy #3: Poor Grounds

• A good grounding scheme helps reduce the 
values of the “hidden” components.

• The key to good ground plane design is 
managing return currents
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managing return currents
• Requires good floorplanning first.



Block Diagram
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Component Placement
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Single Point Grounding

Series Parallel
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• Simple wiring
• Common impedance 

causes different 
potentials

• High impedance at high 
frequency (>10 kHz)

• Complicated wiring
• Low differential potentials 

at low frequencies
• High impedance at high 

frequency (>10 kHz)



Multi Point Grounding
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• Ground plane provides low impedance between circuits 
to minimize potential differences

• Also, reduces inductance of circuit traces
• Goal is to contain high frequency currents in individual 

circuits and keep out of ground plane



D

i(A/cm)IO = total signal current 
(A)
h = height of trace 
(cm)

Current Density
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D
h = height of trace 
(cm)
D = distance from 
trace (cm)

• Illustrates Return Current Flow is directly below the signal trace. This 
creates the path of least impedance.

• Must have Solid return path (i.e. Solid Ground Plane) under the signal trace 
to maintain homogeneous nature of current density.
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Slots in Ground Plane
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Return Current Paths
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Taking a Look at Vias

• Must have Return Path Vias 
next to Signal Path Vias. 

• Notice Large Current 
Density Area flow in return 
path.

• Will have a change in 
impedance with this 
configuration.
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2-Layer PCB showing Current Density of 
PCB trace and Single Return Path Via.

configuration.



Controlled Impedance Vias

• Better Solution is to add 
Multiple Return Path 
Vias.

• Notice minimal Current 
Density Area Flow at 
vias.

• Improved impedance –
reduces reflections.
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2-Layer PCB showing Current Density of 
PCB trace and Multiple Return Path Vias.



Split Grounds
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Split Ground Connected Under ADC
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Connecting Both to Analog Ground
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Ground Plane overlap
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No Split
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ADS1232REF Layout: Top

Analog Digital
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Analog Digital

Power



ADS1232REF Layout: Bottom

FEARLESS engineering
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Thank You!
Any Questions?
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