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Abstract 
 

PCB Artist is a schematic and layout tool provided by Advanced Circuits free of 
charge. The software is available through www.4pcb.com or www.download.com. This 
software is intuitive with substantial libraries and a straightforward component editor. 
This document will provide an instructional overview of many of the tools needed to 
design and fabricate a simple printed circuit board (PCB). Describing this process with an 
example and accompanying screen captures will familiarize the user with the PCB 
interface and development progression from schematic to layout and fabrication.  
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PCB Artist: The Basics of Printed Circuit Boards 
 Printed Circuit Boards (PCBs) are essential elements in today’s society. They are 
found in everything from remote controls, cars and computers. This tool allows electrical 
engineers to create compact, efficient circuit designs to control most of today’s 
electronically-based technologies. Learning the process behind designing and fabricating 
PCBs is essential to working in any industry developing circuits for modern devices. 
Knowledge of this process will also aid in understanding very large scale integrated 
circuit design (VLSI design), which is the development of a single chip by integrating 
thousands or even millions of transistors. 
 This document will provide an overview of the procedure for taking a circuit from 
schematic to fabrication. The format of this document is not that of a tutorial because the 
libraries used to create this tutorial may not be available to the readers of this document. 
Rather, it is an informational application note that follows the development of a 2-layer 
PCB board step-by-step. Development of a PCB in software includes building ones 
schematic and the layout, checking for errors and ordering for fabrication. The basics of 
each step will be described along with screen captures to intuitively illustrate the process. 
A basic understanding of computers, electrical engineering and, more specifically, 
circuits will be assumed. Upon reading this document, one should be able to fabricate a 
basic PCB board and be knowledgeable enough to, with practice and the references 
provided, eventually fabricate more advanced boards. 
  
Project and Schematic Creation 
 The project is the very first thing to be created in PCB design. To begin, open 
PCB Artist and select File->New. The New Design Tab will open. Select New Project 
and assign the project a name and file path. This will create a project where both the 
schematic and layout views can be created, linked and saved. Opening this project in the 
future will open both views of the current design along with the project page. Next, add 
the schematic view by going to File->New. Select New Schematic, designate the 
schematic name and check the box labeled Add to Open Project. The schematic being 
built in this application note is shown below in Figure 1. A banana jack will be used to 
supply the power to the operation amplifier (OPA 365); test points are used to supply Vin 
and read Vout, so the schematic symbols in the PCB Artist screenshots will differ slightly 
from those drawn in this schematic. 
 
 
 
 
 
 
 
 
 
 

Figure 1: Current Input Protection for the OPA365* 
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Component Placement and Wiring 
 On the project’s schematic page, components may now be added and wired 
together to create the schematic. Every component, also called a part, placed in the 
schematic editor has a layout associated with it. This allows for simple transition from 
schematic to layout views. To add a component we can either press F8 or click on the 
chip symbol in the toolbar. This will open the Add Component window shown in Figure 
2. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 2: The Add Component Window 
 

 The library drop box at the top of the page switches between specific libraries and 
all libraries downloaded and placed in PCB Artist’s directory for libraries. A library 
contains a list of parts included within that library. The find button allows for an easy 
search of all available libraries for the part needed for the design. If the components 
needed are not contained within any libraries, then additional libraries must be added 
from the web or external storage to PCB Artist’s library folder. If a library containing the 
required parts cannot be found, the part must be made and added to a new or existing 
library. There is an application note located at 
http://ece480group6.wordpress.com/documents created by Jung-Chun Lu covering the 
creation of parts for PCB Artist. Refer to that document if new components must be 
made. 
 Choose the library containing the part to be used, and then use the component 
drop box to select the part. Check the preview box, which allows a preview of the 
schematic symbol on the left and the PCB layout for that part on the right to be seen. The 
package field will show the type of package the part will come in. This may include 
various types of surface mount and through-hole packages. Use the preview and the 
package field to confirm that the correct part is selected. The reference name of the 
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component may be changed under the Reference name box. This will be displayed on 
your PCB and will allow for ease of assembly. After the correct part is selected, the add 
button will allow the selected part to be placed anywhere on the schematic window as 
many times as desired. Pressing the escape key will quickly revert to the Add Component 
window to find new parts. 
 Continue placing components in a logical fashion until all components have been 
placed on the schematic page. A good schematic design will have inputs on the left and 
outputs on the right. Parts will also be spaced enough to allow for wiring which allows a 
person viewing the schematic to easily determine connections. After all parts have been 
placed, they must be wired together. The Add Schematic Connection button is next to the 
Add Component button on the toolbar. It appears to be a pencil drawing a line. 
Alternatively, clicking Add->Connection also allows for wires to be drawn. Wire all 
components together to finish the schematic. Connections can be made by clicking on the 
x at the end of a component pin and drawing the wire to where the connection must be 
made and clicking there. Multiple wires joining will form a node. Nodes appear as solid 
circles at the intersection of connected wires. Overlapping wires without the node do not 
connect. The Esc key can be used to quickly exit the wire drawing feature. Once the 
schematic is fully wired, it is ready to be transferred to the layout view. The finished 
OPA365 schematic is shown below in Figure 3. 
 

Figure 3: PCB Artist View of OPA365 Input Current Protection 
 
 
Schematic to Layout 
 The transition from schematic to layout is very easy in PCB Artist. After the 
schematic design is complete go to Tools->’Schematic<-->PCB’ and choose Translate to 
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PCB. This will open the PCB Wizard which assists in the transfer. This wizard will 
mostly help specify user interface parameters and information pertinent to ordering for 
fabrication upon completion of the design. Choose next and designate the units to work 
in. The default is mils, which is 1/1000th of an inch, and that unit will be used for this 
document. Many datasheets provide dimensions in both United States customary units 
and International System of Units (SI), so choosing mils or millimeters is a matter of 
preference and familiarity. Precision and board size may also be designated on this page. 
Any parameters specified in this wizard can be changed at any time during the board 
layout process. 
 Continue by specifying the number of layers for the board as well as the types of 
layers, areas to include solder mask, areas to include silk screen, and which layers allow 
traces. A trace is the physical connection between components, sources, inputs and 
outputs on the finished PCB board. A solder mask is placed on the surface of the board 
between traces and components to assuage the possibility of signals jumping across 
connections. A silk screen is what is used to print labels on the fabricated PCB. The next 
page allows for designation of board parameters. This page may intimidate first time PCB 
creators, but there is a parameter definitions button on the page. This takes the user to the 
Advanced Circuits website where an in-depth description of each parameter is provided. 
Set the parameters necessary for the design to be made and click Next. PCB Artist 
provides the option for them to electrically test the board. This is not necessary for many 
first time PCB designers. As boards become more complex, PCB designers may consider 
this option. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 4: The Schematic to Layout Transition Wizard 

 
 
 Next, the Production page requires information to help complete the fabrication 
order after the design is complete. Fill this out with the information specific to the board. 



P C B  B a s i c s    P a g e | 7 
 

 
November, 2012 

There are help buttons provided again if any of the fields are confusing. This page also 
displays the estimated cost of fabricating the PCB. Finally, continue to the page where 
the post-transfer placement of components in the layout view can be specified. The 
default option of arranging outside the board is the best for first-time designers. Click 
next, specify the layout design name and click finish. 
 
PCB Layout Creation and Tracing 
 PCB Artist should now show an outline of the final board with parts assembled 
outside the board outline. The yellow lines connecting the pins of parts are called rubber 
bands and indicate where connections need to be made with traces. This is shown below 
in Figure 5. 

Figure 5: Beginning PCB Layout Creation 
 

 Drag the components into the board outline. Remember to place inputs on the left 
and outputs on the right. Power sources can be placed along the top or bottom of the 
board. With more advanced layouts, the placement of certain elements will be dictated by 
many other factors. An application note for electrical considerations in more advanced 
boards by Matt Affeldt can be found at http://ece480group6.wordpress.com/. For basic 
beginner boards, these power and source placements are good guidelines to follow. 
Before connecting components, it should be mentioned that there is a design rules check 
(DRC) located under Tools->Design Rule Check. Running DRC often while completing 
the PCB design will help troubleshoot any errors made in trace width, spacing, and other 
PCB design rules. Waiting to run DRC until the entire board is completed will generally 
lead to multiple errors and necessitate more troubleshooting than running it multiple 
times during design. 
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 Traces must be added to connect the components together. As traces are added 
between pins, the rubber bands between those pins will disappear. The icon of a pencil 
drawing a line on the toolbar can be used to add traces; Add->Track will also draw traces 
between pins. Unlike wires in the schematic view, traces cannot overlap if they are on the 
same layer. Traces on different layers will be displayed in different colors. This assists in 
spotting any unintentional connections between traces or pins. Right clicking on a trace 
brings up a menu with a variety of options to assist routing traces. These include the 
options to arc the trace, auto route the trace and edit segments of the trace. The properties 
of the trace can also be modified. For signals, trace width should be 15 mils minimum 
and for power it should be 25. Changing the signal style under the properties menu will 
automatically change the trace width. This is also where the layer a trace is on can be 
changed. If the trace does not line up with a pin, the grid can be changed under View-
>Grid to smaller spacing. This allows for more accurate tracing. Finish adding traces 
between all connects except ground. Adding a ground plane and traces to it will be 
covered next. 
 
Creating a Ground Plane and Through-Hole Vias 
 Traces should be added for all components and power sources, but the ground 
trace should be connected to the ground plane placed on the second layer. On a basic 
board, the entire second layer can be designated as the ground plane. There are many 
benefits to dedicating as much of one layer as possible to ground. The electrical 
considerations application note by Matt Affedlt (1) also explores the technical details 
behind this and is a good reference. On a two layer board, an entire layer cannot be 
designated as a power plane. In boards with more than 2-layers, planes can be designated 
as power or ground planes during the schematic to PCB transition. So, to designate the 
second layer as the ground plane the layer must be covered in copper and the net must be 
designated as ground. To make the bottom layer ground, go to Add->copper->Rectangle, 
switch to the second layer by pressing “L,” select the bottom layer, and create a rectangle 
within the board outline. Right click this rectangle and under properties select the Net tab 
and assign ground to the net. This creates a ground plane on the bottom layer of the 
board. The ground plane can be hidden by pressing “F9,” clicking the layers tab and 
removing the check from the ground copper layer box. This will hide the copper pour, 
which designates the ground plane, and allow the rest of the layout to be viewed.  
 To connect to the ground plane a via must be added. A via connects between 
layers and is necessary on multi-layer boards. This can be done by selecting Add->Via 
and placing a via on the board. Right clicking the via and selecting properties will allow 
the size of the via and the size of the hole to be changed. Now, route the pin to be 
grounded to the via, confirm that you would like to join nets in the Join Nets pop-up box 
and make sure the trace width is at least 25 mils. The trace width must be 25 mils 
minimum for all power and ground connections. With the via placed, the Current Input 
Protection Board is complete and all connections have been made. The final board is 
shown below in Figure 6.  
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Figure 6: Final PCB Design 
Fabrication 
 Ordering for fabrication in PCB Artist is very simple compared to similar 
software. The disadvantage is PCBs must be fabricated through Advanced Circuits. 
However, the ease of ordering for fabrication is a very attractive feature for first time 
designers. Clicking the order now button will check for DRC errors and alert if any are 
present, then the Submit Order box will pop up. This box is displayed in Figure 7. Here 
the cost will be displayed and any promotional codes for discounts may be entered. If one 
does not have an Advanced Circuits account, then one must be created through their 
website. Entering the account and password allows the order to be processed, and the 
fabricated board will be fabricated in the turn-around time chosen during the schematic to 
layout transition. 
 
 
 
 
 
 
 
 
 
 
 

Figure 7: Ordering for Fabrication 
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Recommendations 
 This application note introduces an amateur PCB designer to the tools used to 
create a basic board layout. Many of the tools necessary to create a more sophisticated 
board have been touched upon. The documents referred to involving part creation and 
electrical considerations, both located at http://ece480group6.wordpress.com/, will 
provide further information to add to the base knowledge of PCB Artist this document 
provides. With the knowledge these two documents add, the design of more advanced 
boards is possible. 
 Upon obtaining a solid understanding of PCB design in PCB Artist, it is 
recommended to explore other software options as boards become more complex. PCB 
Artist is more intuitive than many other software packages, but doesn’t offer the 
fabrication options of other software or the tools of PCB design software that must be 
purchased. Features to look for in other software include the libraries available, 
simulation software included, complexity of boards allowed, and fabrication options. 
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